Qt -lGL not found error

to overcome this error, the solution worked for me is runnig

sudo apt-get install libqt5opengl5-dev

command it will install a bunch of development files :

The following extra packages will be installed:
libdrm-dev libegl1-mesa-dev libgl1-mesa-dev libgles2-mesa-dev
libglu1-mesa-dev libmirclient-dev libmirclient7 libmirclientplatform-mesa
libmirprotobuf-dev libmirprotobuf0 libprotobuf-dev libprotobuf-lite8
libpthread-stubs0-dev libqt5concurrent5 libwayland-dev libx11-dev libx11-doc
libx11-xcb-dev libxau-dev libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev
libxcb-present-dev libxcb-randr0-dev libxcb-render0-dev libxcb-shape0-dev
libxcb-sync-dev libxcb-xfixes0-dev libxcb1-dev libxdamage-dev libxdmcp-dev
libxext-dev libxfixes-dev libxshmfence-dev libxxf86vm-dev mesa-common-dev
mircommon-dev qt5-qmake qtbase5-dev qtbase5-dev-tools x11proto-core-dev
x11proto-damage-dev x11proto-dri2-dev x11proto-fixes-dev x11proto-gl-dev
x11proto-input-dev x11proto-kb-dev x11proto-xext-dev
x11proto-xf86vidmode-dev xorg-sgml-doctools xtrans-dev zlib1g-dev
Suggested packages:
libxcb-doc libxext-doc libmysqlclient-dev libpq-dev libsqlite3-dev
unixodbc-dev
The following NEW packages will be installed:
libdrm-dev libegl1-mesa-dev libgl1-mesa-dev libgles2-mesa-dev
libglu1-mesa-dev libmirclient-dev libmirclient7 libmirclientplatform-mesa
libmirprotobuf-dev libmirprotobuf0 libprotobuf-dev libprotobuf-lite8
libpthread-stubs0-dev libqt5concurrent5 libqt5opengl5-dev libwayland-dev
libx11-dev libx11-doc libx11-xcb-dev libxau-dev libxcb-dri2-0-dev
libxcb-dri3-dev libxcb-glx0-dev libxcb-present-dev libxcb-randr0-dev
libxcb-render0-dev libxcb-shape0-dev libxcb-sync-dev libxcb-xfixes0-dev
libxcb1-dev libxdamage-dev libxdmcp-dev libxext-dev libxfixes-dev
libxshmfence-dev libxxf86vm-dev mesa-common-dev mircommon-dev qt5-qmake
qtbase5-dev qtbase5-dev-tools x11proto-core-dev x11proto-damage-dev
x11proto-dri2-dev x11proto-fixes-dev x11proto-gl-dev x11proto-input-dev
x11proto-kb-dev x11proto-xext-dev x11proto-xf86vidmode-dev
xorg-sgml-doctools xtrans-dev zlib1g-dev

after this the error had blown away…

 

Note: For some reason you may not to want install development packages (it took ~53Mb space on my computer) if you have better way please comment below.

Reklamlar

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap / Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap / Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap / Değiştir )

Google+ fotoğrafı

Google+ hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap / Değiştir )

Connecting to %s